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Introduction
The ELF simulator is a tool designed to simulate the result magnetic field of some configuration of power
lines, coils, transformers and electric cabinets.
It enables to create a graphic view of power lines, coils, transformer and electric cabinets.
Each graphic item has attached fields like current (effective current), phase, position etc.
The user creates the items in a two-dimension screen but the result can be seen also in a three-dimension
screen.
The result magnetic field of all the electromagnetic items is calculated by pressing the
button.
The magnetic field result is demonstrated by ISO lines in two- and three-dimension screens.

Getting Started
There are 5 different electromagnetic items the user can create:
- Power line.
- Coil.
- Transformer.
- Electric Cabinet.
- Electric pole
In order to create a graphic electric item, the 'Main' tab should be selected.
One of the items buttons should be pressed and then the user should click on the 'Main' screen
at the desired position to locate the item.
Each item has several fields which can be filled by using the 'List Sources' at the bottom of the project.
The list sources include all of the item fields.

Main Object fields
The fields in the source list can be hide or shown using the button
.
The main objects fields in the source list are the following:
1.Name - Every object has some default name which the user can change.
2.Enable - If it is checked the object influence is taken into account in the calculation,
otherwise it is not.
3.Position - The X, Y and Z position of the object on the real world.
4.Current - The effective current in the object.
5.Frequency - The current frequency.
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6.Phase - the current phase.

Accuracy of the calculation
The calculation is done at discrete points on the chosen plane.
By default, the calculation is done every 0.1[m].
As much as this number is smaller the calculation is more accurate but it will take longer.
It is good practice to work with calculation distance 0.1[m].
But for debug purpose it is enough to choose 0.3 [m] or 0.4 [m] and making the calculation faster.
The user can change the calculating points by selecting Project->Calculation Parameters or using the
button

.

Load Map
Up to 20 maps can be loaded to each project.
Many possible formats are allowed including PDF, DWG, DXF, JPG and PNG.
Calibration of the map can be done by Project => Calibrate Map.
The map can be loaded to the project by selecting File->Load Map or the button
The map size as well as other parameters can be changed by the user.

.

Graphic tools
The user can save the project current picture by selecting Tools->Paint.
The current image screen is opened with Windows Paint application.

Power Line
In order to create power line, you should do the following:
Press the button
.
The following window is open:

Fill the appropriate fields and press the OK button.
The cable path can be selected by mouse (the default) or by writing the cable exact positions.
Select position by mouse - Press with the mouse left button to create cable points and mouse right button
to finish the process.
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Write exact position - Uncheck the Create cable by mouse check box than fill the Cable position table.
Use Add Cable Point and Remove cable point to create the desired number of
points

Basic cable fields
Default Z [m] - The height at which the cable is created if the Create cable by mouse option is checked.
Name - The cable name.
Current - The cable current.
Phase - The cable phase.
Color - The cable color, it has only a graphical meaning.
Unbalanced % - The unbalanced of cable, relevant only in the 4-phase case (see detailed explanation
below).
Straight cable - When checked the cable will have only two points, the user can select its starting point
length and direction.
As before the starting point can be selected by mouse or be written directly.

Number of internal lines - Number of phases, the options are 1-5.
If the number of internal lines is bigger than one that the internal structure must be specified.
The important of the structure for the simulation is in order to calculate the distance between the conductor
which has a large impact on the magnetic field result.

Cable internal structure
The cable can have one, two, three, four or five wires (phases).
The internal structure of the cable can be configured or loaded from library.
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After configuring the cable structure, it can be saved to the library
Internal structure fields

Conductor Form - Conductor form relevant only if the number of internal lines is bigger than one.
Conductor Cross Section - Conductor cross section.
Conductor Isolation [mm] - Conductor isolation width.
Calculate Conductor Distance - When checked the distance between the conductors (the cable wires) is
calculated automatically.
When unchecked the user can write directly the desired conductor
distance.
Use library - When checked the internal cable structure is configured according to the selected cable type.
The cable structure field mentioned before are in read only state for this case.
Show history - Show the history of the selected cables by the user.
Library cable - The list of all cables exists in the library, it is empty after the simulation installation and can
be filled by the user.
Save to library - Save the current cable configuration to library.
Remove from library - Remove current configuration from library.

Creating several cables in one step
Sometimes several cables with internal structure should be created.
The user can select the number of cables, the distance between them and their span direction.
In general, the cables can be created one above the other below by side etc.
The span direction is selected automatically by the software or by the user choice.
Number of complex cables - The number of cables where each one can have more than one phase.
Distance between complex cables [m] - the distance between the cables.
Auto span direction calculation - If checked the span direction is selected automatically, otherwise the user
should specify the vector span direction.
The vector span size is unimportant only its direction.

Coil

In order to create a coil, you, should do the following:
1.Press the button
.
2.Press with left mouse button at the position where you want to position the coil.

The field created by the coil is found by dividing it to small lines and calculating these lines field.
This number of lines influence the calculation precision, the bigger it is the calculation will be more accurate
but
will take longer.
The user can change the calculating parameters by selecting Project => Calculation Parameters or by
pressing the button .
The relevant field is Number of lines in coil loop.
The coil field additional to the standard are:
1.Theta - The theta angle of the coil orientation.
2.Phi - The phi angle of the coil orientation.
3.Radius -The radios of the coil loop.
4.Length - The coil length.
5.Num loop - The number of the coil loops.
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Example of a few coils is shown in the figure bellow.

Electric Cabinet
In order to create a cabinet, you should do the following:
1.Press the button
.
The following window appears.
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In the list there is a list of optional cabinet, from which the user should select one.
When a cupboard is selected by mouse click on it its main fields appear.
The user can change the value of those fields.
The position fields (X, Y and Z) must be filed by the user.
The cupboard has several fields which can be seen and changed by using the 'List Sources' at the bottom
of the project.
When the user selects the cabinet, its data is shown at the head of the 'List Sources'.
The user can delete a cabinet from the list by selecting it and pushing the 'Delete' button, but this
only apply to cupboard the user created and added to the list.
The basic shapes that were not created by the user can't be deleted.
The way to create and add new cupboard to the list is explained in the next sections.
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Transformer
In order to add a transformer to the project you should do the following:
1.Press the button
.
The following window will appear.

In the list there is a list of optional transformers, from which the user should select one.
When a transformer is selected by mouse click on it its main fields appear.
The user can change the value of those fields.
The position fields (X, Y and Z) must be filed by the user.
The user can make its selection final by pressing the 'OK' button or by clicking twice on the selected
transformer.
The transformer has several fields which can be seen and changed by using the 'List Sources' at the
bottom of the project
The dimension of the transformer box height, width and length can be configured.
One more important field is the shielding factor.
The field created outside the box by the objects inside the transformer is decreased by this factor.
Next to the shielding factor in the 'List Sources' there is a field Decrease factor [%], this is
a read only field which show the object magnetic field in percentage from its original value (when there is
no shielding).
The decrease factor changes automatically when the user changes the shielding factor.
The '3D Figure' field influence only on the 3D graphic appearance, it controls the 3D box view.
See bellow an example to two transformer 3D view.
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Electric Pole
In order to add electric pole to the project you should do the following:
1.Press the button
and then press the main window.
The following window will appear.

The electric pole window has the following fields:
1. Electric Pole Type - There are several different electric pole options, each has its own shape and cables.
2. Create by Mouse - If checked the electric pole will be created after the user press the 'OK' button by
pressing on the main window with
the left mouse button.
To stop creating poles press the right mouse button.
If not checked the electric pole will be created at the points below which are created
by the user.
3. Current - The current of all the electric pole cables.
4. Sag - the sag of all the electric pole cables.
3. Add Pole Point - Add a point were electric pole will be put.
4. Remove Pole Point - Remove the last pole point which was added by the user.
5. Press the 'OK' button.
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All the poles data and its cables can be changed after their creation, including position, angle, sag current
etc.
Below there are two examples of electric poles created in this way.

Electric source list (ES)

The Electric source list (ES) include information about every electric object which was added by the user.
In order to show or hide it use the button
The electric source can be viewed in a separate window by pressing
When the user selects an object in the main frame the appropriate line in the (ES) is highlighted.
The object data can be changed in the ES.
Every electric object has some unique field and some which are basic field and are common
to all the electric objects.
The basic fields are:
- Delete button, delete the cable from the project.

Name - Every object has a default name which the user can change.
Comment - The user can add a comment to every object, the comment field is hidden by default.
To make it visible the user should check the box at the top of the ES.
Show - If the show box is checked the object is seen on the graphic screens, if it is not
it is hidden.
After the calculation is done all the objects automatically becomes visible.
Enable - If the enable box is checked the object is taken into account in the field calculation,
otherwise it is ignored.
Position (X, Y, Z) - Describe the object position, it can be changed by the user, the effect is seen
immediately at the graphics screens.
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Current / Max Current - The object current at full capacity.
Actual current - The current at partial capacity which is controlled by the I [%] which is shown in the
Calculation and 3D tabs.

Performing Calculation

In order to do the calculation, the desired electric configuration should be built (cables, coils etc...).
Then the button
should be pressed.
A calculation message with a progress bar appears and the calculation process begin, this would usually
won't take more than a few minutes.
The calculation result is ISO lines painted at the 'Calculation' screen and in the '3D' screen.
The calculation is done in one of the three plans XY, XZ or YZ.
If the user chooses to do the calculation in the XY plane than also the calculation height is Z [m]
which can be defined in the calculation tab.
Every electric element has a 'Current' field and 'Actual current' field which are shown in the electric source
list.
The actual current is the element current multiply by the I [%].
The default value for I [%] is 100% and it is used to calculate the magnetic field in partial power by all the
elements.
The calculation height and the I [%] can be seen in the figure below.

Also, the user can find the magnetic field at a specific point by pressing the button
The following fields appear at the 'calculation' screen.
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The user can see the magnetic field at some point by moving the mouse above it or by writing
its coordinate position at the appropriate fields.
In the figure bellow the calculation was done in the XY plane where Z = 1 [m].

Add shape to library
The procedure for adding new shape to transformer and electric cabinet is almost identical.
There are two option to create the new shape:
- Create it from scratch,
- Using existing shape and changing it.

Create library shape from scratch
To create shape from scratch, use empty box (see figure below).
For transformer use the Empty option from the transformer library and for electric cabinet use the Empty
option from its library.
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Build the shape by creating the coils and cables
When finished select all the relevant element by dragging the left mouse or by clicking on all the elements
while pressing the ctrl button.
Then, while the mouse is above one of the elements press the mouse right click, a window as in the
example below will be opened.

Select 'Create Transformer'/'Create Cabinet' and the following window will be opened.
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The name of the new shape should be written and if the Use auto connection is checked than the
connection point of the new shape should be defined.
The connection points are the points where a cable should connect to the new shape.
The points are for defined for cable automatic connection to the shape.
One can define the connection mouse by directly writing them in the window or by mouse clicking on the
appropriate points.

Create library shape based on existing shape
Select one of the shapes in the library and locate it in the project.
Select all the relevant element by dragging the mouse left button or by clicking each one while pressing ctrl
button.
Then when the mouse is above one of the elements right click it.
This time select the option Ungroup (see figure below).

This will make all the parts of the original shape as separate parts.
This enable the option to change their values or adding new elements.
Then by select the relevant elements and right click while the mouse is above one of them the Create
Transformer/Cabinet option can be used.
The rest of the procedure is the same as before.
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Calculation Parameters

In order to see the calculation parameters, the user should press the button
or use the link Project - >
Parameters.
The magnetic field calculation is done on a restricted plane, it can be the XY plane the XZ plane or the YZ
plane.
The borders of the system axis view is defined under Axis system limits:
The borders of the calculation area are defined in the Calculation data.
Xmin is the minimal value for which the calculation is done.
Xmax is the maximal value for which the calculation is done.
Ymin , Ymax ,Zmin and Zmax has the same meaning for the other axis.
The calculation is done for a restricted number of points on the selected plane.
The distance between the calculation points is defined by ∆X, ∆Y and ∆Z.
The coil magnetic field is found by dividing it to straight lines.
The number of line to which each loop in the coil is divided is defined in the field
'Number of lines in coil loop.
General remark
The calculation time will be shorter if the area calculation is shorter, the distance between the calculation
points is larger and the number of lines in coil loop is smaller.
But the calculation accuracy is better for shorter distance between the calculation points and large
number of lines in coil loop.
So, for debug purpose the following is recommended:
1. Use large number for the distance between the calculation points (0.5 [m]- 1[m])
2. Use small number for the number of lines in coil loop.
For the final calculation it is recommended to use default value, or if one wants a very good accuracy
it is possible to use shorter distance between the calculation points and larger number
of lines in coil loop.
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Map and axis system

The load map parameters are defined by in the load map window.
Up to 20 maps can be loaded in each project, the maps can be shown in the 2D screen as well as the 3D
screen.
This window is shown when one presses the button
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The meaning of the load map fields is explained bellow.
Show 2D map by height - If checked the map on 2D will be selected automatically according to the
calculation height (Z).
The selected map will be the one which is the closest to the calculation height.
If it is unchecked than the user will select the map to present in the 2D screen.
The user selects it in the main toolbar under Map on 2D.
Change calculation limit - If checked than the calculation limits are changed to be the same as the map
limit, otherwise they are not changed.
Start Point X [m] - The X starting point of the loaded map.
Start Point Y [m] - The Y starting point of the loaded map.
End point X [m] - The X end point of the loaded map.
End point Y [m] - The Y end point of the loaded map.
Loadmap Colors - The original option shows the map without any change while the other options change its
colors.
Load new map - If checked than a new map is loaded according to file chosen in 'Map file' field.
Otherwise the fields in the 'Load Map' window describe the map which was already loaded.
That is, in a case were a map was loaded and then there is a need to change its limits
there is no need to load a new map, only to change those of the existing map.
Map file - The file in which the map is plotted.
Copy - Copy map that already exist in the project, for example, if the map exists at height 0 [m] it can be
copied also to height 3 [m].
Export map - Export the project map to file.
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Map Calibration
For DXF and DWG the scaling is done automatically, although it can be changed in the same way as other
formats.
The map calibration can be done by checking the Scale map option (see above figure) and filling the scale
value.
Another option is after loading the map to select Project => Calibrate map, the following window will be
opened.

If Calibrate by mouse is unchecked the user should write how to 'correct' the map.
That is what is currently 100 [cm] on the map should be some other distance.
If Calibrate by mouse is checked, after clicking OK the flowing window will be opened:
:

The user is asked to click on two points on the map and to write the real distance between them.
If no calibration is needed for the X direction the user can press Skip.
The same is done also for the Y direction.

Map crop
After loading a map, it can be cropped and the result can be used in each of the project 20 maps.
Press mouse right click and select Map crop.

The following window is opened.

19 / 32

ELF Simulator

The user is asked to select which project map should use the result map cropped.

Set point on map to be axis system center
In order to set a specific point on the map to be the axis system center press
The following window is opened.

.

The new axis system center can be clicked by mouse or written directly.

Axis system plan and symmetry
The axis system plane is selected by the buttons
To select if the presented axis system should be symmetrical use
.
The system can be symmetrical with the same scale on both axis or not.
If the system is not symmetrical to more object can be seen in the screen but the result does
reflect the exact reality and for instance circle might looks like ellipse.

Edit and connect
After adding several objects to the project, it is possible to edit them as a group.
Cable can be extended and change internal point position and also it can automatically
connect to transformer or electric cabinet.
Edit group
Select all the relevant objects and press
The following window is opened.

.
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Write the values in the field that should be changed and press O.K or Apply.
If a field is not filled it will have no impact on the selected group.

Auto connection to transformer and electric cabinet
Select the cables that should be connected and press
The following is opened.
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The ELF 100 identify if there are close transformer or electric cabinet to the cable and offer to connect it.
This window also appears immediately after cable creation if it is close to a relevant object.
Check the appropriate box and press OK.
Connect or extend cable

In order connect or extend a cable press
The cable edges will become blue.

.

Extension - Press on the desired cable and then on another cable point or on an empty point.
The cable will be extended to the point clicked by the mouse.
If the cable is part of group of several phases than also the phases will be extended
accordingly.
Connection - Press on the desired cable and then on another cable point which is part of electrical cabinet
or transformer.
A new single-phase cable will be created between the two clicked points.
Its phase and current will be the same as the clicked cable.

Threshold Limit Value

The threshold limit value of the magnetic field is the allowed limit.
It is not recommended to be exposed to magnetic field above the threshold limit.
In order to put the threshold value in addition to the ISO lines the user should be in the calculation screen
and then press the button

.

The tool-bar at the calculation screen will look like this:

A 'TLV' field was added, TLV means Threshold Limit Value.
Its default value is 4 [mG].
The threshold limit line is plotted as a black dashed line, see the following example.
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The 3D Screen
Every object in a project can be viewed in two or three dimensions.
The figure in the three dimensions can be rotated by pressing the left mouse button and dragging it.
Zooming is done by pressing the right mouse button and dragging it or by the mouse wheel.
The screen can be shifted by pressing the mouse wheel and dragging it or with the buttons in 3D toolbar.
The use of the buttons in the 3D toolbar screen is explained in the following.
- Show/hide the ISO line and the up tool-bar in the 3D screen.
- Show/hide the interior of an object in the 3D screen (relevant for electric cupboard and transformer).
Bellow there are two figures describe the before and after pressing this button.
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-

- Show the XY plane in the 3D.
- Show the XZ plane in the 3D.
- Show the YZ plane in the 3D.
- Go to the start 3D view.
After shifting and rotating the 3D screen it is always option to go back to the original view.
- Create floors, after pressing this button the following window is opened.
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As default there is only one floor if, for example, the user chooses to add one floor (total number of
floor is two) at height of 3 [m], the result is as seen in the figure bellow.
- Hide/Show the Iso lines and toolbar in the 3D screen.
- Show only the inside of the transformer and electric cabinet in the 3D screen.
That is it hides the graphical 3D image.

- Set the rotation axis position in the 3D screen.
When the 3D image is rotated whether by dragging the window or by the buttons it is rotate around
axis which can be shown and changed by the user.

Adding 3D image
There are several images which can be added to the 3D screen.
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The images has no influence on the magnetic field and they are shown only for graphical purpose.
To add image use Project => Add Graphic Object, the following window will be opened.
See below a example of a few images.

Report B vs distance
The project report give full information on the Magnetic field vs distance for each object.
This option is only available for 64-bit operating system.
Press Project => Report and the following window will be opened:
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The user can select which objects to include in the report.

The User reference point is relevant if the user defined Calculation Points using
.
If it is checked than for each calculation point the magnetic field is calculated and also the distance relative
to the reference point.

Calculation and real data points

In order to write the magnetic field at specific points press
The following window will be opened:
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The calculation points can be added by mouse or by directly write their position.
See the orange text box in the example below.

Real data points
The actual measured magnetic field can be inserted to the simulation by Project => Real data points.
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Created with the Standard Edition of HelpNDoc: Full-featured multi-format Help generator

B vs (X, Y, Z) Graph
The graph of B vs (X, Y, Z) intend to give additional perspective to the ISO lines.
The graph meaning for each of the three coordinate is the same.
So, for illustration purpose only the B vs X case is considered.
In order to see the B vs X graph use View -> B vs X.
The example (see figures below) is of a simple one phase cable.
A graph is plot at the XY plane.
The plan is at Z = 1[m]
For each (X, Z = 1), position there are many magnetic field values (actually infinite), this includes all the
points with position
(X, Z = 1) but with different Y position.
For each such X value there is a minimal and maximal magnetic field value.
In the graph B vs X this two values are connected with straight line.
As an example, let’s consider the two figures bellow.
Let consider the point X = 4 [m], at this point from the ISO line figure it is seen that the minimal value is
close to zero.
While the maximal value is between higher than 10 [mg] (between 10 [mg]to 20 [mg]).
Indeed, at the B vs X graph at point X = 4 [m] a line is plotted between value near 0 [mG] to value a close
12 [mg].
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Project detail
The project detail can be seen by View -> Project Detail.
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In order to hide the 'Project Detail' tab uncheck View -> Project Detail.
The project details fields are shown in the figure bellow.

Unbalanced
In general, the currents in each phase of a cable will not be identical due to customer usage.
In order to simulate this situation, the user should change each phase current in cables, electric cabinets
and transformers.
The ELF 100 enable to use automatic tools to insert the unbalanced factor.
Each of the electric elements: cables, transformers and electric cabinets has the following fields in the
Electric Source list.

R [%] - The current percentage from the maximal current in the R cable (phase 0).
S [%] - The current percentage from the maximal current in the R cable (phase 120).
T [%] - The current percentage from the maximal current in the R cable (phase 240).
Unbalanced [%] - The total unbalanced of the object, the method of its calculation is explained below.
Auto calculation - If checked the fields R [%], S [%] and T [%] are in read only mode and their values is
automatically calculated by the software according
to the value of Unbalanced [%].
If it is unchecked than Unbalanced [%] is in read only mode and its value is calculated
according to the R [%], S [%] and T [%].
Use unbalanced - If checked the cable current will be according to the values of R [%], S [%] and T [%]
otherwise the cable current will be
calculated only according to the maximal current.
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Unbalanced calculation
The unbalanced is defined as maximal current deviation from the average divided by the average, see
below the details of the calculation.
R, S and T are the current percentage in the corresponding cables.
Average  (R + S +T) / 3
Rdev  Abs (R - Average)
Sdev  Abs (S - Average)
Tdev  Abs (R - Average)
Maxdev  Max (Rdev , Sdev , Tdev )
Unbalanced  (Maxdev /Average) * 100
The current in N cable (returning current) is found using Kirchhoff la , where IX is defined as the current in
the X cable.
IR + IS + IT = IN

General settings
To set the general appearance of the project press Project => General Settings.

All the fields describe the graphical view of the result except for the Electric current field which
select the project current type.
It can be changed only if the project is empty.
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